Jump to content
Aero Precision - Premier C130 Aftermarket Support
Aero Precision - Premier C130 Aftermarket Support
Aero Precision - Premier C130 Aftermarket Support
 
Paulo

Engine Power Loss

Recommended Posts

Paulo

Loss of Torque (2500 Lbs), accompained of TIT and Fuel Flow with TD AUTO @ Cruise with BARV @ ON position!

At Null engine goes to Normal parameters!

With BARV OFF, Engine goes to normal parameters!

Share this post


Link to post
Share on other sites



Lkuest

I'm assuming a BARV is a Bleed Air Regulator Valve, and when you say "accompanied of TIT", you mean TIT dropped with torque, and not increased.

The TD Amp's job is not to maintain power, but to maintain temperature based on the throttle setting. If the TIT is low while the TD Amp is in AUTO, then there is an error with a signal being supplied to the TD Amp, or there is an error with the Amp itself, a setting or malfunction,

When you lose air, you lose power for two reasons. Jet engines love more air, both to increase power through expansion, and also to keep the combustion chamber cool. If you lose air, you lose power immediately since there is less air to expand, but also the loss of cooling air causes an increase in TIT, and results in the TD Amp to pull fuel back. This all produces a loss of torque and fuel flow while maintaining TIT.

I cannot emphasize this enough, before doing anything, ensure your indications are accurate! TIT to within 6 degrees of actual as measured with a test set and all thermocouples verified good and connected properly. Torque indicator recalibrated and set to within 50 in-lbs of actual. Swap the Fuel Flow gauge with a known good one for good measure, then reverify the problem.

Why the engine goes to normal when the Regulator Valve gets turned off is interesting. If the TIT was to remain normal, I would say the Regulator Valve was mis-tuned and the TD Amp was doing its job. Since the TIT is also low, we know the TD Amp is not doing its job (above crossover only). Even if the Regulator was malfunctioning, the TD Amp is definitely having an issue. The fact that the valve affects the TD System operation means they may be connected electrically in some way, like the power/signal wires may be chafing together. If the fuel control was perfectly tuned and we suspected the TD Amp was just inop, we would see high TIT with bleed air open, not low TIT.

To check if it is an electrical problem, check power going to the TD Amp using a TD Amp Test Set, then cycle the bleed air valve and see if the power at the Amp changes. There are two types of power going to the Amp, so check them both.

If I misunderstood you, and the TIT is high during the malfunction, and not low, then you have a TD Amp malfunction AND a bleed air regulating valve balance issue causing you to lose 2500 in-lbs.

 

Share this post


Link to post
Share on other sites
Paulo

Thanks for your information !!!

I have replaced the Bleed Air Regulating Valve and the Relay Box witch is connected to the TD Amplifier !

I have preformed a Engine Run-up and now the engine is stable in every throttle setting !

Pushed to Crossover

To 910 degrees

 to 970 degrees

1010 degrees

Always Stable !

Thank you very much anyway !!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Champion Aerospace




×