Jump to content
Aero Precision - Premier C130 Aftermarket Support
Aero Precision - Premier C130 Aftermarket Support
Aero Precision - Premier C130 Aftermarket Support
 
Sign in to follow this  
Nate Anderson

Help me troubleshoot!

Recommended Posts

Nate Anderson

I have an ECHS problem. One of our strech J's has all of the RH pallet locks, and PLCUs, not communicating with the MFCD. Actually it's all RH side and the LH side ramp locks that cannot be controlled/not communicating. Our bird just came back from Depot for the LAIRCM mod and now the pallet locks are jacked up. I've been looking in the WD but can't find anything that's in common with one whole side or the other. Any input is welcome/needed as I'm not too "savy" on this particular system. Please and thank you

                                                 SIGNED

                                      Mr. Sickof Chasingmytail

Share this post


Link to post
Share on other sites



tinyclark

Did you get this working. I would contact WRALC first. Find out what the TCTO directs as far as disconnecting systems. It sounds like something was disconnected to me. 

 

  • Like 1

Share this post


Link to post
Share on other sites
hehe

There are huge cannon plug disconnects for echs that kill entire sides.  look forward of booster reservoir and aft near the ring sections where aircraft is extended.  most likely one of those is loose

  • Thanks 1

Share this post


Link to post
Share on other sites
Nate Anderson
On 4/15/2018 at 1:37 PM, tinyclark said:

Did you get this working. I would contact WRALC first. Find out what the TCTO directs as far as disconnecting systems. It sounds like something was disconnected to me. 

 

We did thanks. The mod guys left a cannon plug half connected

Share this post


Link to post
Share on other sites
Nate Anderson
On 4/15/2018 at 5:41 PM, hehe said:

There are huge cannon plug disconnects for echs that kill entire sides.  look forward of booster reservoir and aft near the ring sections where aircraft is extended.  most likely one of those is loose

Thanks for the help, you hit the nail on the head. Cannon plug was half connected near hydraulic reservoir. Thanks

Share this post


Link to post
Share on other sites
hehe
9 hours ago, Nate Anderson said:

Thanks for the help, you hit the nail on the head. Cannon plug was half connected near hydraulic reservoir. Thanks

No problem man, glad to see it was an easy fix

Share this post


Link to post
Share on other sites
tinyclark

So much for Op Chking systems that were disturbed. I'd like to see if that is called out in the TCTO. If it call for disconnecting, surely the check was needed.

 

Glad it was an easy fix.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

Champion Aerospace




×