Jump to content
Aero Precision provides military aviation aftermarket solutions for c-130
Sign in to follow this  
PauloFerreira

RDR-1F WEATHER RADAR

Recommended Posts

HELLO!!

I'm having a problem with this type of weather radar!

R/T (Receiver / Transmitter) P/N-2070401-0101 are burning all the time when the plane goes in flight.

Displays (Pilot and Navigator) in Test Mode and Mapping only shows the three colors on the bottm of the displays, even if we change the Range!

Thanks in advance for your help!

Best Regards!!!

Share this post


Link to post
Share on other sites
20 minutes ago, PauloFerreira said:

HELLO!!

I'm having a problem with this type of weather radar!

R/T (Receiver / Transmitter) P/N-2070401-0101 are burning all the time when the plane goes in flight.

Displays (Pilot and Navigator) in Test Mode and Mapping only shows the three colors on the bottm of the displays, even if we change the Range!

Thanks in advance for your help!

Best Regards!!!

Start by checking the waveguides between the R/T and Antenna.

 

Share this post


Link to post
Share on other sites

Hi Gary!

We have already checked the waveguide!

the problem is that when the plane is grounded, everything seams to be normal apart the colors (just in the bottom of the display.)

when the plane goes in flight R/T burns. Is this a sign of over consumption?

Share this post


Link to post
Share on other sites

I'm not sure Paulo.   All my career was on APN-59 on C-130's and Multi-mode on C-5 with a couple of years on MH-53 with APQ-158 Terrain-Following.   Never worked on color weather radar.   Need to get an answer from someone else on the color weather radar.

 

Share this post


Link to post
Share on other sites

I am not sure what you mean by burning. Are they actually overheating and smell burnt when the aircraft lands? Or do they just shut down and not come back on when the aircraft is sitting on the ground? Have you tried changing the antenna anyway, or swapping it with another antenna from a different aircraft? 

Share this post


Link to post
Share on other sites
On 3/3/2019 at 3:01 AM, tinyclark said:

I am not sure what you mean by burning. Are they actually overheating and smell burnt when the aircraft lands? Or do they just shut down and not come back on when the aircraft is sitting on the ground? Have you tried changing the antenna anyway, or swapping it with another antenna from a different aircraft? 

Hi Tiny,

When we pass from warm up to Map the R/T just shuts down because it seams to burn the power supply. we have changed the antenna, swapped with onother palne, it's the same!!

The other problem is : when we are able to put the system running (because it works some times) we have only three little dots in the center bottom of the dysplay.

Share this post


Link to post
Share on other sites

Paulo,

I wish I could be more help. I don't have any wiring diagrams to look at, especially for the video problem. Does the R/T sit in the aircraft cabin. Is the antenna a dish or flat array? I think this is similar to the RADAR we had on the C-141. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...