Jump to content
Aero Precision provides OEM part support for military aircraft operators across more than 20 aircraft
Sign in to follow this  
Nate Anderson

Help me troubleshoot!

Recommended Posts

I have an ECHS problem. One of our strech J's has all of the RH pallet locks, and PLCUs, not communicating with the MFCD. Actually it's all RH side and the LH side ramp locks that cannot be controlled/not communicating. Our bird just came back from Depot for the LAIRCM mod and now the pallet locks are jacked up. I've been looking in the WD but can't find anything that's in common with one whole side or the other. Any input is welcome/needed as I'm not too "savy" on this particular system. Please and thank you

                                                 SIGNED

                                      Mr. Sickof Chasingmytail

Share this post


Link to post
Share on other sites

Did you get this working. I would contact WRALC first. Find out what the TCTO directs as far as disconnecting systems. It sounds like something was disconnected to me. 

 

Share this post


Link to post
Share on other sites

There are huge cannon plug disconnects for echs that kill entire sides.  look forward of booster reservoir and aft near the ring sections where aircraft is extended.  most likely one of those is loose

Share this post


Link to post
Share on other sites
On 4/15/2018 at 1:37 PM, tinyclark said:

Did you get this working. I would contact WRALC first. Find out what the TCTO directs as far as disconnecting systems. It sounds like something was disconnected to me. 

 

We did thanks. The mod guys left a cannon plug half connected

Share this post


Link to post
Share on other sites
On 4/15/2018 at 5:41 PM, hehe said:

There are huge cannon plug disconnects for echs that kill entire sides.  look forward of booster reservoir and aft near the ring sections where aircraft is extended.  most likely one of those is loose

Thanks for the help, you hit the nail on the head. Cannon plug was half connected near hydraulic reservoir. Thanks

Share this post


Link to post
Share on other sites
9 hours ago, Nate Anderson said:

Thanks for the help, you hit the nail on the head. Cannon plug was half connected near hydraulic reservoir. Thanks

No problem man, glad to see it was an easy fix

Share this post


Link to post
Share on other sites

So much for Op Chking systems that were disturbed. I'd like to see if that is called out in the TCTO. If it call for disconnecting, surely the check was needed.

 

Glad it was an easy fix.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...