Jump to content
Aero Precision provides OEM part support for military aircraft operators across more than 20 aircraft

Pitchlock pucker factor .......


Recommended Posts

So there we were, an engine giving 104% performance, 29.85"Hg air pressure,

and 20°C OAT. Engage the pitchlock, push the throttle to take off. Watch the

overspeed at 105% rpm, fuel flow at 1500pph, torque around 10000"lb.

Next moment fire warning light flashes on, fuel flow shoots to 2000pph, torque

rising rapidly, and rpm on the way down. Then everything goes back to pitchlock

settings, ....... and again the fire warining, and fuel and torque rise, rpm drop, and

back again.

Fighting the instinctive throttle back to prevent overtorque/flame-out situation while

pitchlocked, yet still trying to analyze the situation, I finally opted for feather shut-

down.

Lots of extremely wide eyes in the control, I find myself thinking "double rum and

coke would be good about now", and realizing that I'm in the Magic Kingdom. So

reset everything, cool down the engine and start up again. Everything all happens

again except this time there is no response on the throttle when I tried to throttle

back. Another feather shut down!!

Decided that because the engine had been standing unpreserved for a looonnnggg

time, it must be the fuel control governor that [email protected] out. One FCU change later

and we try again. Initial pitchlock check good - joy!! 20 minutes later (and another

feather shutdown), I'm shaking from adrenaline overload.

After consulting with the prop shop brains trust, the decision was made to replace

the valve housing. Again everything checked good, with 3 back-to-back pitchlocks

successful. Work through an entire run sheet, and get to the pitchlock step again,

back to square one!!!

Slaved in a spare prop main control conduit - no change! Started investigating the

test cell cables and junction boxes. Finally found the 'sync box' of the test cell had

a burnt component. The main control and the fire detector leads run in the same

harnass. So I'm guessing damaged wires inside the harnass shorted between the

prop control and the fire circuit.

Disabled the fire circuit and replaced the prop control box, now everything is

working as advertised. My arms, however, feel like I've been wrestling bears or

something .......

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...