Jump to content
Aero Precision provides OEM part support for military aircraft operators across more than 20 aircraft

GTCP85-180L APU DOESN'T SUPPLY BLEED AIR


Recommended Posts

Our GTC85-180L APU starts and runs well. However,  it doesn't supply bleed air. We have isolated the load control valve. We equally isolated the APU control switch as well as pressure regulator. We cleaned in-line filter. Despite these steps,  APU still doesn't supply bleed air. It is strange to us and I am wandering if anyone has had this type of experience before and the possible solution. Thanks. 

Link to post
Share on other sites
2 hours ago, pjvr99 said:

"not supply air" - do you mean load control valve is not opening, or load control valve is not holding load?

 

We believe the load control valve is not opening. We confirmed that the load control valve is not the issue because we tested it on another APU and it worked. 

Link to post
Share on other sites
  • 10 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...