Jump to content
Aero Precision provides OEM part support for military aircraft operators across more than 20 aircraft
Sign in to follow this  
Hanif

RDR 1 F radar

Recommended Posts

  

Problem  Hi! I am technician of BAF 61-0962 C-130B aircraft. Presently we are operating in MONUSCO, Dr Congo under United Nations. The weather radar of our aircraft is RDR-1F. I am having a problem with this type of weather radar. The problem is that a permanent noise found right side both the radar indicators(Pilot & Navigator side) all times & antenna one sweep weather available and another sweep weather missing when the aircraft goes in flight. The problem remain same even if we change range. Another problem is that when climbing weather not available both the radar indicators.         

Rectification : To solve the problem, I have done the following rectification jobs :

1) At first we remove all the sub units of weather radar (such as R/T, control unit & 02x indicators) and cleaned with alcohol.

2) Then we check the wiring of all cables and connections according to manual TM-130B-2-13S-1 and found ok.

3) Then we perform antenna checkout procedure according to manual TM-130B-8S-1 and found normal.

On ground operation carried out found everything normal and Test mode all color band ok. But when the aircraft goes in flight problem remain same.

4) Then we change radar R/T. 

On ground operation carried out found ok but in air problem remain same.                   

Share this post


Link to post
Share on other sites
Posted (edited)

Have you done ground power runs to see if you can duplicate it?

Edited by hehe

Share this post


Link to post
Share on other sites
On 7/20/2020 at 5:04 AM, Md ismail khan said:

Mr hehe, can you explain it elaborately please. I cannot understand duplicate.    

Sorry.  Have you done engine runs on the ground and done multiple configurations of power levels to get the plane to shake on the ground?

 

Or have you done a full shakedown of the wiring while someone watches the system?

Share this post


Link to post
Share on other sites

Not familiar with that RADAR. Given all you have changed, try changing the waveguide between the R/T and the antenna.Corrosion may cause false targets.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...