Jump to content
Aero Precision provides OEM part support for military aircraft operators across more than 20 aircraft

AP/105 Alt hold issue


Recommended Posts

We have a bird that has had an alt hold write-up since about 2010. It has been through CWB change in 2014 and a PDM 2016. The fail is that once level flight is established alt hold is engaged, all ann lights req do come on, the plane does not hold alt. It begins to fall. Flight director is good the bars appear on the ADI to pull up or down as needed however the elevators do not move, and there is no trim light to indicate it is trying to correct at all. On the ground it cannot be duplicated with the ttu. All parts have been changed or swapped no change. 

Link to post
Share on other sites

Yes, both copilot and pilot side provide the issue. ALT SEL does work on the ground with the ttu. Tail number 1041. All lights do illuminate as they should. As of yesterday the autopilot breakout box was used as well with no faults found. It's due to fly this am for ops check. 

Link to post
Share on other sites

Yep.93-1041 Flew they noted that the trim lights were working and that there is feeling of "trying" to correct just that it felt weak. So weak that it can't maintain the hold. However, with just AP not coupled to flight director the feel is stronger to move the elevator with the servo. 

Link to post
Share on other sites

Three questions right now.  It is strange that the servo is not driving if the trim tabs aren't keeping up.

Does the Trim Monitor Test work?

Does the normal elevator trim system work as advertised?

What parts have been replaced or swapped?

 

Link to post
Share on other sites

Yes the trim mon works. The normal trim system does work as advertised. Parts changed list. Elevator servo, flight director 1, autopilot amp, both adcs, the ads, both mode couplers, pilots mode selector, accerationtion sensor was changed once during this issue in 2011 it's due to be changed again. 

Link to post
Share on other sites
On 3/24/2017 at 7:05 AM, C130chick said:

Yes, both copilot and pilot side provide the issue. ALT SEL does work on the ground with the ttu. Tail number 1041. All lights do illuminate as they should. As of yesterday the autopilot breakout box was used as well with no faults found. It's due to fly this am for ops check. 

YIKES just reread the initial post started in "2010"...

OK the aircraft will climb to or descend to the selected altitude in flight BUT once ALT Hold is selected the aircraft will not maintain alt.

All lights work (elevator trim) as they should for normal operations.

If you engage only the AP without the FD the AC tries to maintain but cannot ("feeling is stronger") but does it maintain altitude? 

 

Have them try the IAS function during ALT SEL climb this will tax the elevator trim system without the barometric input to the AP system.  Have them use the calculated 4 eng climb speed which will be slower than normal speeds flown which will increase the pitch angle and require more input from the trim system. This "Climb test should be up to a "cruise ceiling" altitude say 23-25,000 feet to encounter various air densities/TAS

GOOD LUCK!!! 

Link to post
Share on other sites

Okay. I know I'm behind. Ive been out of town away from work. So friday I changed the servo to a new one and sat a new air speed sensor was installed, the one that is about the size of a beer can, Monday it flew and was signed off as good to go.  Not sure about my confidence that it will fix it long term but over all at the time it's fixed. 

 

Thank you.for all the assistance and information. 

Link to post
Share on other sites

I was going to suggest some extreme troubleshooting. Doing an Op Ck on that aircraft and another, using the TTU-205 and quickly bumping the altitude up or down 500' to measure the pressure exerted by the trim motor or servo using some sort of tension gauge. Hopefully it won't come back to haunt you. 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...